Child pages
  • Whisker Tracking Installation
Skip to end of metadata
Go to start of metadata

Contents

From pre-built binaries

There are two ways to install. It's simplest to use a pre-built package. If there isn't one, you'll need to install by building the source code. The source code builds and has been tested on Ubuntu 10.10, Fedora 10, Windows XP, and OS X 10.5 and 10.6 on both 32 and 64-bit machines. If a pre-built installer is available for your system, it will be found here.

Quick-start

Install the command line tools.

1. Download the pre-built package for your system.

2. If using an installer, run it and follow directions. If installing from a compressed archive, open the archive and copy files to the desired directory. If given the option, it is recommended you do an Everything install.

3. (optional) Add the {WhiskerTracking}/bin directory to your environment's PATH. Doing so will allow you to call the command line utilities from any directory. The installer might do this for you.

4. (optional) Add the {WhiskerTracking}/ui directory to your environment's PATH. Doing so will allow you to call ui2.py, the graphical interface, from any directory.

(Optional) Install the Python environment.

Note

The graphical user interface is written in Python 2.6. Installation of a Python 2.6 environment, including several Python libraries, is required to run the graphical user interface, but is not required for the command line tools used for automated analysis.

Install the following in order. Be sure to choose the right installers for your system.:

  1. Python 2.6
  2. numpy 1.4.1
  3. scipy 0.8
  4. matplotlib 0.99.3
  5. pygame 1.9
  6. aggdraw 1.2a3
Note

The recommended method for installing Python and Python libraries varies from system to system. On Windows, use installers (.msi or .exe files). On Linux, use your system's built-in in package manager (for example apt-get). Linux users might consider using easy_install or pip instead. On OS X 10.5, use .dmg based installers. A 64-bit installation for OS X 10.6 is a special case. Many installers do not install x86_64 compatible binaries. See Installing a 64-bit Python environment on Mac OS X 10.6 for more.

Warning

Python comes pre-installed on OS X. There are Python installers available for OS X, but they may install themselves in strange places. On OS X do not install Python itself unless you know what you're doing.

(Optional) Install the Matlab environment.

Add {WhiskerTracking}/matlab to your Matlab path. This adds the following m-files:

  • LoadWhiskers.m
  • LoadMeasurements.m
  • SaveMeasurements.m

With the path properly adjusted, one can use the doc or help commands in Matlab to learn how to use these commands.

  • No labels